Pages

The now daily Time Machine Error

Rarely a day goes by now that Time Machine doesn't produce the dreaded Time Machine Error warning: "Unable to complete backup. An error occurred while copying files to the backup volume." Ironically I get this more on my Mac Pro with dual internal hard drives that check out fine rather than my little MacBook with the slow USB based drive for backup.

Since Time Machine runs hourly I'll get 23 to 47 backups that work fine, then the error. It's always a single file that seems to blow out the backup and generate the message: 

Time Machine Error. Unable to complete backup. An error occurred while copying files to the backup volume.
I haven't encountered this on my MacBook Pro yet, only on my Mac Pro. The time machine icon in the menu bar shows this:

I first encountered this problem at the beginning of June and it is definitely a byproduct of the 10.5.3 update. Jeff McCord has documented similar problems on his blog. There seems to be two solutions that work for me:

1) Try again. About half the time just telling Time Machine to try again seems to work.

2) Look at the backup volume. If there is a file on your backup volume that ends in "inProgress" then drag it to the trash can. You'll be prompted to enter your password. Once done try Time Machine again.

I'm getting a lot of hits on this blog from people searching for Time Machine Error so hopefully this abbreviated solution set will help them clear the error until Apple fixes it.

I have read reports of people saying this may be related to using Growl—which I use with several of my applications—though I only seem to be seeing this error consistently on my Mac Pro. Though a relatively minor error that is easily recovered from, often by doing nothing but letting Time Machine try again, I would really like to see it eliminated.

30 comments:

Partners in Grime said...

Definitely seems to be an error introduced with 10.5.3. I have had the Time Machine error message three or four times since updating my 24-inch iMac. I'm not using Growl (and never have).

Anonymous said...

The mds process seems to be the culprit with my Time Machine problems. When I force quite mds, Time Machine works again. mds is the meta data server.

RG-6 said...

I am still on 10.5.2 with Growl and haven't had any time machine errors. I will be doing the 10.5.3 update this weekend (I clone my hard drive prior to doing updates - just in case). I'll post back if 10.5.3 introduces this error.

Pedro Alberto Vera said...

That error cost me 3 months of backups, about 100 movies in iTunes, and over 1000 TV episodes in iTunes. I made the mistake of running Disk Utility on the drive after the first few Time Machine errors.

The result: Disk Utility bailed out, then marked the drive as read-only. I was using the drive (1 TB) both as a Time Machine for my Mac Book Pro, and as the iTunes media storage folder.

Never again.

I tried many times with Disk Warrior, but no luck. I ended trying to rescue as much as I could out of the read-only drive into another, much smaller, external drive. After I pulled out as much as I could, I formatted it. The errors went away, and it passed both Disk Utility and Disk Warrior with flying colors.

A week later I bought a second external drive, so now Time Machine has the drive by itself, and my media is in the new drive. If Time Machine kills the drive, all I lose is backups. If I lose the media drive, it is being backed up by Time Machine so I won't be losing all of it.

Anonymous said...

David,

It's 10.5.3. I never had a problem on my Mac Pro until 10.5.3 and now I get this error once in a while.

I do NOT have Growl installed.

I'm thinking 10.5.4 will fix it.

Update Bot said...

Since I have DiskWarrior, I don't even mess with Disk Utility. Too much potential to mess things up. And DW can handle the hard-link directories in Time Machine backups.

Bot

stevebert said...

I'm running 10.5.3 with Time Machine backing up to a 1TB Time Capsule. The only time I've seen backup failures is when I close the lid of my MacBook Pro during a backup. It only happens rarely and Time Machine seems to recover in the next backup.

MikeP said...

I'm also using a 1 TB Time Capsule (wirelessly) on a late '07 iMac running 10.5.3 and Growl and am yet to see an error. I do wonder what the difference of error rate is using Time Capsule as opposed to 3rd party drives?

Josso said...

At least 10.5.4 can't be far away. :)

Robert W. said...

Funny, I got this error just before clicking on your blog to see what's up for the day. I get this error almost daily on my Mac Pro, however I have not got this error on my MacBook Pro that uses Time Capsule. BTW how is the new MBP?

I do not use Growl and it sure seems that this started happening after the 10.5.3 update. In all cases so far telling TM just to start over works.

Anonymous said...

I think it's 10.5.3
I use a late 07 Macbook pro with a Lacie 500GB FW drive. Never had the problem prior to 10.5.3 and I don't use Growl.

David Alison said...

@Robert W: I'm loving the MBP. The keyboard is excellent and the screen real estate is a huge help. When I travel—which I'm doing a lot of this summer—I don't feel like I'm compromising too much.

@Pedro: that's tough man - losing data is never fun. I would caution anyone that doesn't already do it to use a dedicated backup drive, not to partition it and use part for backups, part for live storage. If you really feel compelled to split up that big disk then don't put anything useful on the non-backup partition.

Eytan said...

Ihave seen the error about 3 times myself, on my Mac Pro - I have started up the backup again and it has gone away. I use Growl, and I am on 10.5.3

I would caution use of DW to fix the time machine backup unless you are 100% sure you have the right version (4.1). You could get in big trouble otherwise.
Apple also cautions against the use of it for two things - Pedro, sounds like you did not even partition the drive. BIG no no - Time machine does enough disk intensive things, you don't want to ALSO use it as a media storage server - and if it was read only, you could have copied the media files off of it!

Tom Zimmer said...

David,

one thing to think about, is whether the TM failures were related to files that were in a particular directory. If they were, then it could be that TM is timing out while trying to access/backup an open file. I know this shouldn't be a problem for TM, but on the outside possibility that it is, you could simply include the specific folder in the exclude list for TM.

just my thoughts,

Tom

David Alison said...

@Tom: unfortunately it's a different file in a different location nearly every time. I've seen the same file occasionally but not that often.

Anonymous said...

I first saw this TIme Machine's message just today.

After searching in the Internet I found some possible solutions. Now my Time Machine works again with no problem. Please read ALL the post before doing something.

1. Check that the drive you are using is updated to the last drivers and firmware that the drive's manufacturer proposes.

2. Check that your computer's name in Sharing Preferences is as much compatible as it can with Time Machine. There's an article in Apple, you should read and make the changes as needed. It refers to another Time Machine's problem but you must do it as it seems that it affects Time Machine in this.

Here's the article
http://docs.info.apple.com/article.html?artnum=306928

3. Some users in discussions propose to see at the log file to see what's the problem that stopped backing up. Very good idea and this can be done by using the Terminal (found in Utilities - you might need to enter an Administrator password before entering the command) and the command:
sudo grep backupd /var/log/system.log

Here's the discussion
http://discussions.apple.com/thread.jspa?threadID=1203637&tstart=0



In my case of Time Machine problems, in which I had to do with two kind of problems, I needed to do the following that worked for me:

1. It seemed that there was a problem with my 2 extrernal hard drives when I had them connected on the same 800 firewire port, the one next to the other, (chain). That was causing the Time Machine's backup disk not to be recognized correctly and sometimes not even appearing on the desktop. I upgraded the "firmware" and the "WD Buttons" for my two WD500 MyBook Pro with the latest version and I have chosen to put the Time Machine's drive on the 400 firewire port while the other remained on the 800 port (just to be sure...). No such problem appeared again. My drives worked with no problem, so did Time Machine.

I thought that my problems with Time Machine came to an end, but... Today... came the problem you describe here. So...

2. I tried the "sudo" command described above and found that "Mail" application was causing the backup to stop (one of "Mail"'s mailboxes trash). I closed the application.
3. I changed my Machine's Name as described above.
4. I haven't tried to trash anything or make any changes in my Time Machine's drive. The drive was initially prepared with "Partition Map Scheme: GUID Partition Table" and "Format: Mac OS Extended (Journaled)", it still is.
5. I chose "Backup Now" from the menu, which it was successful!
6. After the first successful backup Time Machine automatically renamed the folder that keeps the individual backups to the name that I gave in Sharing Preferences, as described above. So, try not to change names or other things in the hard drive that keeps your backups (other than upgrading drivers-firmware if necessary as described above)...

I already successfully used the Backup Now function five times with no problem. I tried it even when using the "Mail", that caused the problem, and it worked, so the problem is not the "Mail" application itself but Time Machine. In YOUR machine there may be another application or file that is causing the problem to Time Machine. The solution is not to trash the file or the application or not use it at all.

My hard drive Time Machine related problems started after applying the 10.5.2 update. The problem you described here started after applying the 10.5.3 update.

So until Apple finds a solution to the problem (maybe with another upgrade):


7. To be sure that no other such problem will occur I will NOT USE the automatic backup again. Instead I will keep Time Machine "OFF" and from time to time I will take manually backups by choosing "Backup Now", after a restart and no application open. Just to be sure...


I hope this to be as helpful to you as it was for me!

Good luck
Kyriakos, Greece

Qwintine said...

Is this issue fixed with the last 10.5.4 update?

Kind regards,
Qwintine

David Alison said...

@Qwintine: Unfortunately I don't see anything in the KB article about it. I'm going to install it now since I have nothing else to lose and see if it fixes it.

Anonymous said...

10.5.4 does not fix this problem, at least on my first-gen Mac Pro.

Jeff McCord said...

Thanks for the link, David! I've yet to encounter any more Time Machine errors now that I realize you have to dismount the drive.

Whew... that was a painstakingly rough couple of days when 10.5.4 came out!

GREAT BLOG by the way!
Jeff McCord

Anonymous said...

I have this happen to me every few days too. Just the nondescript error message, then everything goes back to working fine when I tell it to back up now.

Scott Schram said...

I had no problems 10.5.0 to 1.5.2.

They started at 10.5.3, and continue in 10.5.4. There's nothing in the 10.5.4 release notes about Time Machine.

No growl, never used it.

Retrying (or just letting it retry next hour) works for me.

Anonymous said...

I'm running 10.5.4 on a PowerPC G5 and get the time machine error every few days. Don't know why.

Anonymous said...

Just started happening to me on 10.5.4 Is there a more reliable backup solution at this point?

David Alison said...

@Anon: I still get this error all the time. Fortunately now all I do is tell Time Machine to try again and it always seems to work. If you leave the machine when it has the error then it will retry in an hour on it's own so you don't have to do it manually.

Anonymous said...

Hey everybody,

I ran into this issue over and over, finally ran the terminal command to show me the log and it gave me some useful info. The terminal command, just to recap, is sudo grep backupd /var/log/system.log


Once I looked through the log, I found that files were crapping out in iDVD:

Nov 2 15:24:40 Macintosh-2 /System/Library/CoreServices/backupd[8557]: Error: (-36) SrcErr:YES Copying /Applications/iDVD.app/Contents/Resources/Dutch.lproj/iDVD Help/gfx/idvd1081.jpg to (null)
Nov 2 15:25:02 Macintosh-2 /System/Library/CoreServices/backupd[8557]: Error: (-36) SrcErr:YES Copying /Applications/iDVD.app/Contents/Resources/Dutch.lproj/iDVD Help/gfx/idvd1084.jpg to (null)
Nov 2 15:49:57 Macintosh-2 /System/Library/CoreServices/backupd[8557]: Error: (-36) SrcErr:YES Copying /Library/Application Support/iDVD/Themes/iDVD 3/003_Gen_Y.theme/Contents/Resources/BackgroundMovie.NTSC.mov to (null)
Nov 2 15:49:59 Macintosh-2 /System/Library/CoreServices/backupd[8557]: Error: (-36) SrcErr:NO Copying /Library/Application Support/iDVD/Themes/iDVD 3/003_Gen_Y.theme/Contents/Resources/BackgroundMovie.NTSC.mov to /Volumes/Time Machine Backups/Backups.backupdb/user/2008-11-02-150921.inProgress/8BD24926-0D63-48F1-97A8-79F9837D9E3E/Macintosh HD/Library/Application Support/iDVD/Themes/iDVD 3/003_Gen_Y.theme/Contents/Resources
Nov 2 15:49:59 Macintosh-2 /System/Library/CoreServices/backupd[8557]: Stopping backup.


In summary, a bunch of files I never use, so I deleted them, reran Time Machine, it worked.

Iris said...

It is not possible for me to delete the .inProgress file on my LaCie USB drive. It "looks" like it is going to Trash but it just stays on the LaCie after taking my pw.

I tried to overwrite the backup with a similarly named file, but Finder told me the "name" was too long.

I tried to use Disk Utility but got the message that the LaCie Drive could not be unmounted.

Other than reformatting, what is left to do?

Iris

David Alison said...

@Iris: Have you restarted the machine? That may clear the lock on the file. Also ensure you have all of the latest patches installed (run Software Update). I haven't had a Time Machine error since the last update. Hope this helps...

Mark Uhde said...

I lost several files to Time Machine using a backup made with Time Machine in Snow Leopard and had similar errors in the log, but in my case I didn't get those failure warnings! Time Machine said it was successful!

My story is here:
http://markuhde.blogspot.com/2009/09/failure-bad-not-warning-of-failure.html

And my log file that looks similar is here:
http://markuhde.blogspot.com/2009/09/heres-incriminating-log-file.html

Take a look and tell me if it looks similar, it does to me...

David Alison said...

@Mark: Good blog post and you are spot on when you say the GUI should warn you of backup errors. The reason I love Time Machine is that it makes backing up something that happens without even thinking about it. If there are errors in a backup I want to be notified immediately.

Looking through your error log it's very different than what I've been experiencing. Mine are mostly individual files that have been locked and I have received TM error messages on them. HOWEVER, this is on Leopard (my Mac Pro), not Snow Leopard. I upgraded to SL on my MacBook Pro and just started scanning my logs and did not see any errors.

If you haven't already I think you should contact Apple Care and see how they respond to this. Let me know how that goes.